$2000 invested need help tech issue!

no rules!

Moderators: bigwave, AirMail, pillow

johnw884
Posts: 2
Joined: Thu Jul 07, 2016 5:59 pm

$2000 invested need help tech issue!

Postby johnw884 » Thu Jul 07, 2016 6:01 pm

Any advice or similar experiences you can share are greatly appreciated!



I have a 2013 Suzuki Rmz 450. My bottom end was on it's way out so I replaced with a new crank assembly with all the bearings, at the same time put in a new piston, rings, cam chain, replated the cylinder and clutch basket. A few days ago completed the project and started it up. Started with no issues.... However at an RPM just about idling the bike will make a clicking/ tinging/ pinging/ ticking sound(difficult to describe). Once it is revved beyond a certain point the sounds diminishes.. My personal guess is something to do with the decompression spring being worn out on the camshaft?? To be clear the engine sounds good besides this noise at a lower RPM. Please any help I'm out of ideas! Thank you
Popkum Motor Park
Posts: 20
Joined: Wed Aug 01, 2012 4:23 am
Province/State: British Columbia
Contact:

Re: $2000 invested need help tech issue!

Postby Popkum Motor Park » Fri Jul 08, 2016 2:04 pm

My 2010 RMZ 450 had the same issue and cost me $2500. Turned out to be the bearings on the connecting rod and the bearings have a flaw (Google it) and break down/wear over time (not much either if you ride regularly). Have to re-do the motor often. Sold mine.
http://www.popkummotorpark.com
Facebook: PopkumMotorPark
Twitter: PopkumMotorPark
Instagram: popkummotorpark
YouTube: popkummotorpark

Return to “motoRcross chat:”

Who is online

Registered users: Bing [Bot]